This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I have been following the step by step guide for building Wireshark on windows 7 using the source, but when I run nmake -f Makefile.nmake verify_tools I encounter the following output:

tools/win64-setup.sh: sed: command not found exec: --checktag: not found Can't find Qt. This will become a problem at some point. tools/win64-setup.she: sed: command not found exec: --appverify: not found NMAKE : fatal error U1077: '"C:\Program Files\Bash\bash.EXE"' : return code '0x7f' Stop.

What am I missing that it throws so many errors, and how can I fix them?

asked 09 May '14, 09:49

Thomas%20G's gravatar image

Thomas G
26459
accept rate: 100%

edited 09 May '14, 09:51

What is the output of

nmake -f Makefile.nmake verify_tools

(09 May '14, 11:31) Kurt Knochner ♦

That is the output of

nmake -f Makefile.nmake verify_tools

I did not go any further with the installation since it seemed obvious at this point that it wasn't going to work.

(09 May '14, 11:37) Thomas G
1

Erm... Yes ;-))

Sorry, my head just banged against the keyboard and typed my first comment all by itself ;-)) Please forget that question....

Now: If you start bash and then type: sed <ENTER>. What happens?

(09 May '14, 11:40) Kurt Knochner ♦
C:\Program Files\Bash\bash.EXE : sed: command not found
(09 May '14, 11:43) Thomas G
1

O.K. some questions:

  • The Base directory for Cygwin is usually c:\cygwin. Your bash is in c:\program Files. How comes?

  • Did you select the package that contains sed during the Cygwin installation (it's in the Base package)?

  • Did you install the 64bit Cygwin package or the 32Bit package?

  • What is your Cygwin version (will be shown on the first setup screen)?
(09 May '14, 11:50) Kurt Knochner ♦

The version of Cygwin I installed defaulted to c:\cygwin64. Since I just used the batch file shown on the page without checking to see if it was correct, the batch file did not set the path correctly earlier. When this became a problem earlier I solved it by installing win-bash, which got me to the point I'm at now. I've now removed the reference to that Bash from PATH and changed the line in the batch file from

set PATH=%PATH%;C:\cygwin\bin

to

set PATH=%PATH%;C:\cygwin64\bin

Now I'm getting the error which originally caused me to install win-bash, which is:

'bash' is not recognized as an internal or external command, operable program or batch file.

Can't find Qt. This will become a problem at some point.

'bash' is not recognized as an internal or external command, operable program or batch file.

NMAKE : fatal error U1077: 'bash' : return code '0x1'

Stop.

when I run verify_tools.

I selected sed during install, and both sed.exe and bash.exe are present in my cygwin64 directory.

I am using Cygwin version 2.850 (64 bit)

(09 May '14, 12:20) Thomas G

I successfully installed after installing the 32 bits version of Cygwin. Thank you for your help.

(09 May '14, 13:18) Thomas G

How did you solve the sed error. My sed is running in bash but not while running in cmd.

(26 May '14, 08:29) aman

I stopped getting the sed error when I stopped using win-bash and went back to the Cygwin bash. I was getting the error because I had not installed the sed package when I installed win-bash. I also needed to install the 32 bits version of Cygwin, the 64 bit version doesn't work for some reason. Another reason you might be getting that error could be that your PATH variable isn't pointing to the right location.

(26 May '14, 10:04) Thomas G

Thanks. it helped.:) sed error is solved, but now I get an error in bash.exe: igncr:invalid option name. How do I solve this.?

(28 May '14, 05:59) aman
showing 5 of 10 show 5 more comments

Did you try to install the 32 bits version of Cygwin?

permanent link

answered 09 May '14, 12:30

Pascal%20Quantin's gravatar image

Pascal Quantin
5.5k1060
accept rate: 30%

I have tried it with 32 bit Cygwin, and was able to successfully run verify_tools. I now get the result

Error: The contents of 'C:\Wireshark-win64-libs\current_tag.txt is (unknown). It should be 2014-04-16

Can't find Qt. This will become a problem at some point. Checking for required applications:

Followed by all the applications and their paths. I have looked at the path referenced by the error, and there is nothing in that folder. What should I do about that?

(09 May '14, 13:02) Thomas G

I installed my build successfully. Thank you for your help.

(09 May '14, 13:19) Thomas G
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×254
×193
×103
×58
×40

question asked: 09 May '14, 09:49

question was seen: 3,895 times

last updated: 28 May '14, 05:59

p​o​w​e​r​e​d by O​S​Q​A