This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I've recently been given some "home grown" dissectors that were compiled for Wireshark 1.6.3. The current version that is on my Mageia 3 Linux system is 1.8.15. Can those older .so implemented dissectors be used w/o recompiling?

asked 25 Jun '14, 07:09

heymanj's gravatar image

heymanj
11112
accept rate: 0%

additional information: undefined symbol rpc_auth_flavor

(25 Jun '14, 07:12) heymanj

No the API is not frosen and there has been API changes so plugins has to be recompiled with the version they are to be run with.

permanent link

answered 25 Jun '14, 08:31

Anders's gravatar image

Anders ♦
4.6k952
accept rate: 17%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×637
×11
×2

question asked: 25 Jun '14, 07:09

question was seen: 1,053 times

last updated: 25 Jun '14, 08:31

p​o​w​e​r​e​d by O​S​Q​A