This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hello wireshark gurus,

I've been banging my head against the computer screen for 2 days with this problem. Newly installed wireshark, runs fine under root but when I run it as a non-root user I get "No interface for capture to be done", I know it has to do with the rights and permissions, I gone through the creating wireshark group, adding the user, elevating the file permission to 750 and setting setcap. I doesn't matter what I do, wireshark just doesn't display interfaces to capture on when I run it as a non-root user. Does wireshark need a static ip address, can it work normally in a multihome computer (more than one NIC) or does the code need to be modified? I'm new to linix and wireshark so please dum down your explanations for a newb. Many thanks.

asked 15 Oct '14, 05:33

valenski's gravatar image

valenski
1111
accept rate: 0%

Add yourself to the wireshark group, logout, login again, test. Is this what you did?

(15 Oct '14, 08:47) Jaap ♦

The key is to run setcap on the dumpcap binary. See my answer and comments in the following questions:

https://ask.wireshark.org/questions/19675/error-when-running-wireshark-on-ubuntu-as-non-root-user
https://ask.wireshark.org/questions/25242/wireshark-and-linux

See also other similar answers:

https://ask.wireshark.org/questions/16343/install-wireshark-on-ubuntu

Regards
Kurt

permanent link

answered 21 Oct '14, 06:56

Kurt%20Knochner's gravatar image

Kurt Knochner ♦
24.8k1039237
accept rate: 15%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×1

question asked: 15 Oct '14, 05:33

question was seen: 2,033 times

last updated: 21 Oct '14, 06:56

Related questions

p​o​w​e​r​e​d by O​S​Q​A