This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I have read the other post concerning Wireshark and Yosemite OSX. I have a similar problem which Wireshark not loading. However, the recommendation are not working. Attached is the error I am seeing when I run from terminal.

PapaMac$ sudo wireshark
Password:
2014-10-17 20:30:51.763 defaults[1190:246204] The domain/default pair of (kCFPreferencesAnyApplication, AppleAquaColorVariant) does not exist
2014-10-17 20:30:51.807 defaults[1191:246211] The domain/default pair of (kCFPreferencesAnyApplication, AppleHighlightColor) does not exist

(process:1180): Gtk-WARNING **: Locale not supported by C library.
    Using the fallback 'C' locale.

(wireshark-bin:1180): Gtk-WARNING **: cannot open display:

Thanks to all.

asked 17 Oct '14, 19:41

JohnRutl's gravatar image

JohnRutl
11112
accept rate: 0%

edited 18 Oct '14, 00:49

Guy%20Harris's gravatar image

Guy Harris ♦♦
17.4k335196

1

What happens if you try to do

sudo xterm

and what happens if you try to do

xterm

(without the sudo) and what happens if you try to do

wireshark

(without the sudo)?

(18 Oct '14, 00:50) Guy Harris ♦♦
1

I had the same issue with the actual Yosemite rollout. I uninstalled both X11 and Wireshark from my new install. I then installed X11 and Wireshark in that order. It all works now and seems to be stable. I hope this helps for you.

(18 Oct '14, 04:39) dotnetbrett

Since the update of Yosemite Wireshark appear to work OK. thanks again.

(20 Oct '14, 19:13) JohnRutl
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×15

question asked: 17 Oct '14, 19:41

question was seen: 14,244 times

last updated: 14 Nov '14, 16:19

p​o​w​e​r​e​d by O​S​Q​A