This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.
Extracting '/cygdrive/c/development/Wireshark/Wireshark-win32-libs/gtk+-bundle_2
.24.23-1.1_win32ws.zip' into '/cygdrive/c/development/Wireshark/Wireshark-win32-
libs/gtk2'
unzip:  cannot find either /cygdrive/c/development/Wireshark/Wireshark-win32-lib
s/gtk+-bundle_2.24.23-1.1_win32ws.zip or /cygdrive/c/development/Wireshark/Wires
hark-win32-libs/gtk+-bundle_2.24.23-1.1_win32ws.zip.zip.

ERROR: Couldn't unpack '/cygdrive/c/development/Wireshark/Wireshark-win32-libs/g
tk+-bundle_2.24.23-1.1_win32ws.zip'

NMAKE : fatal error U1077: 'C:\cygwin64\bin\bash.EXE' : return code '0x1'
Stop.

How shall I solve it?

asked 18 Nov '14, 13:18

aman's gravatar image

aman
36151620
accept rate: 0%

edited 19 Nov '14, 01:23

grahamb's gravatar image

grahamb ♦
19.8k330206

Did the download of the bundle succeed? If not you may have to down load it manually. If you are behind I proxy you may have to fix the proxy settings.

(18 Nov '14, 22:29) Anders ♦

i.e. Do you have the file gtk+-bundle_2 .24.23-1.1_win32ws.zip in C:\Development\Wireshark\Wireshark-win32-libs?

(19 Nov '14, 01:18) grahamb ♦

@grahamb: ya I have the gtk+-bundle_2 .24.23-1.1_win32ws.zip in C:\Development\Wireshark\Wireshark-win32-libs folder but still its showing the error in unpacking..

@anders: I tried to do it the way you suggested, but it gets stuck in this step.

(19 Nov '14, 10:24) aman

Ok, back to the beginning, what do you get for nmake -f Makefile.nmake verify_tools?

(19 Nov '14, 13:33) grahamb ♦

This is what I get for verify_tools

Checking for required applications: cl: /cygdrive/c/Program Files (x86)/Microsoft Visual Studio 12.0/VC/BIN/cl link: /cygdrive/c/Program Files (x86)/Microsoft Visual Studio 12.0/VC/BIN/link nmake: /cygdrive/c/Program Files (x86)/Microsoft Visual Studio 12.0/VC/BIN/nmake bash: /usr/bin/bash bison: /usr/bin/bison env: /usr/bin/env grep: /usr/bin/grep /usr/bin/find: /usr/bin/find peflags: /usr/bin/peflags perl: /usr/bin/perl C:\Python27\python.exe: /cygdrive/c/Python27/python.exe C:\Qt\5.3\msvc2013_64\bin\qmake: /cygdrive/c/Qt/5.3/msvc2013_64/bin/qmake sed: /usr/bin/sed unzip: /cygdrive/c/oraclexe/app/oracle/product/11.2.0/server/bin/unzip wget: /usr/bin/wget

(20 Nov '14, 06:53) aman

This may be a problem

unzip: /cygdrive/c/oraclexe/app/oracle/product/11.2.0/server/bin/unzip

I think it should be unzip from the cygwin package

(20 Nov '14, 07:24) Anders ♦
showing 5 of 6 show 1 more comments

Haven't we been here before?

unzip: /cygdrive/c/oraclexe/app/oracle/product/11.2.0/server/bin/unzip

You have to remove that (broken) Oracle version of unzip from your path.

permanent link

answered 20 Nov '14, 07:20

grahamb's gravatar image

grahamb ♦
19.8k330206
accept rate: 22%

I fixed the unzip error, but I am not seeing flex:/usr/bin/flex in verify_tools. How to fix that?

(20 Nov '14, 08:41) aman

I fixed that out but while executing all command I get NMAKE : fatal error U1073: don't know how to make '../../tools/make-dissector-reg'

what is this due to?

(21 Nov '14, 10:33) aman

You'll need to add some more context of the output preceding this error.

(21 Nov '14, 14:36) grahamb ♦

NMAKE : fatal error U1073: don't know how to make '../../tools/make-dissector-re g' Stop. NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 12.0 \VC\BIN\nmake.exe"' : return code '0x2' Stop. NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 12.0 \VC\BIN\nmake.exe"' : return code '0x2' Stop. NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 12.0 \VC\BIN\nmake.exe"' : return code '0x2' Stop.

(24 Nov '14, 06:39) aman

That's the output after, we need whatever came immediately before.

(24 Nov '14, 06:52) grahamb ♦

link -dll /out:mate.dll /NOLOGO /INCREMENTAL:no /DEBUG /MACHINE:x86 /Saf eSEH /DYNAMICBASE /FIXED:no mate_parser.obj mate_grammar.obj packet-mate.obj mate_setup.obj mate_runtime.obj mate_util.obj plugin.obj ....\epan\libw ireshark.lib ....\wsutil\libwsutil.lib c:\development\Wireshark\Wireshark-win3 2-libs\gtk2\lib\glib-2.0.lib c:\development\Wireshark\Wireshark-win32-libs\gtk2 \lib\gmodule-2.0.lib c:\development\Wireshark\Wireshark-win32-libs\gtk2\lib\gob ject-2.0.lib mate.res Creating library mate.lib and object mate.exp cd .. cd minet "C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\BIN\nmake.exe" / -f Makefile.nmake

Microsoft (R) Program Maintenance Utility Version 12.00.21005.1 Copyright (C) Microsoft Corporation. All rights reserved.

NMAKE : fatal error U1073: don't know how to make '../../tools/make-dissector-re g' Stop. NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 12.0 \VC\BIN\nmake.exe"' : return code '0x2' Stop. NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 12.0 \VC\BIN\nmake.exe"' : return code '0x2' Stop. NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 12.0 \VC\BIN\nmake.exe"' : return code '0x2' Stop.

C:\Development\wireshark>

(24 Nov '14, 07:19) aman

You're building a plugin that has an older makefile and is still referring to the shell based version of make-dissector-reg. That's gone and only the Python version is supported now.

Edit your makefile.nmake, find the line that calls make-dissector-reg and add .py to the end of the filename. Look at the makefile.nmake for the mate plugin if you get stuck.

(24 Nov '14, 08:20) grahamb ♦
showing 5 of 8 show 3 more comments

I got this problem because of the Qt path. I followed the instructions here - https://www.wireshark.org/docs/wsdg_html_chunked/ChSetupWin32.html and one step includes setting the Qt path as:

set QT5_BASE_DIR=C:\Qt\Qt5.3.0\5.3\msvc2013

However, the correct setting for Qt in my case was:

set QT5_BASE_DIR=C:\Qt\Qt5.3.2\5.3\msvc2013_opengl

Changing the set corrected the problem for me.

permanent link

answered 30 Oct '15, 03:19

PaulOfford's gravatar image

PaulOfford
131273237
accept rate: 11%

You will likely have to adjust the paths as per the preceding statement in the developers guide:

Set the following environment variables, using paths and values suitable for your installation:

regardless, this isn't really an answer to the somewhat old question, but a separate build environment config issue

(30 Oct '15, 03:48) grahamb ♦

Hi Graham,

Yes don't get me wrong - I'm not complaining about the setup guide, I'm just recording the reason why I got the error in the subject line.

Best regards...Paul

(30 Oct '15, 03:58) PaulOfford

Plus I made the same error as reported elsewhere and downloaded the 32 bit version of Qt on my 64 bit machine. So the correct QT5_BASE_DIR set is:

set QT5_BASE_DIR=C:\Qt\Qt5.5.1\5.5\msvc2013_64

More easily done than you think because if you click on the Download Now button on the Qt website, it downloads the 32 bit version.

(30 Oct '15, 05:23) PaulOfford
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×1,620
×21

question asked: 18 Nov '14, 13:18

question was seen: 2,993 times

last updated: 30 Oct '15, 05:23

p​o​w​e​r​e​d by O​S​Q​A