This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I installed Wireshark on my Ubuntu 10.04 netbook but it won't recognize either of my RJ45 LAN or wireless Atheros card. Can anyone help me out?

asked 30 Sep '10, 12:56

Grafixx01's gravatar image

Grafixx01
1222
accept rate: 0%

edited 30 Sep '10, 23:36

Jaap's gravatar image

Jaap ♦
11.7k16101


What does dumpcap -D say? If it's something like

dumpcap: There are no interfaces on which a capture can be done

Then you may need to enable capture privileges (CAP_NET_ADMIN and CAP_NET_RAW) in dumpcap. Instructions for doing this can be found in many places including

permanent link

answered 01 Oct '10, 08:31

Gerald%20Combs's gravatar image

Gerald Combs ♦♦
3.3k92258
accept rate: 24%

I did that and got the message that you stated above.

However, I followed the instructions and it can't find "packetcapture" so it still doesn't recognize the Atheros card.

(01 Oct '10, 12:45) Grafixx01

Which instructions did you follow? "packetcapture" is the name of a group that you create.

(01 Oct '10, 13:29) Gerald Combs ♦♦

Are you running Wireshark as root or is your user in the right group? When I run it as a normal user, it doesn't see the cards. When I sudo wireshark it runs and sees the network cards. (Of course, I do get the warning that it is dangerous to run Wireshark as root. So you may want to add your user to the group that can Wireshark rather than sudo.)

permanent link

answered 19 Nov '10, 21:03

stoner455's gravatar image

stoner455
1
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×80
×8

question asked: 30 Sep '10, 12:56

question was seen: 4,074 times

last updated: 19 Nov '10, 21:03

p​o​w​e​r​e​d by O​S​Q​A