This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hello,

today I downloaded the newest Wireshark sources and tried to run "nmake Makefile.nmake setup", but the following error occured:


*** . ***
No HTTP proxy specified (http_proxy and HTTP_PROXY are empty).
Downloading . into '/cygdrive/c/Users/LucaAdrian/Desktop/Wireshark', installing
into USBSRV\wireshark\Wireshark-win64-libs-1.12
File `index.html' already there, will not retrieve.
Extracting '/cygdrive/c/Users/LucaAdrian/Desktop/Wireshark/.' into '/cygdrive/c/
Users/LucaAdrian/Desktop/Wireshark/USBSRV\wireshark\Wireshark-win64-libs-1.12'

*** gtk2 *** No HTTP proxy specified (http_proxy and HTTP_PROXY are empty). Downloading gtk2 into '/cygdrive/c/Users/LucaAdrian/Desktop/Wireshark', installi ng into USBSRV\wireshark\Wireshark-win64-libs-1.12 --17:17:52-- http://anonsvn.wireshark.org/wireshark-win64-libs/tags/2014-10-01/ packages/gtk2 => `gtk2' Connecting to anonsvn.wireshark.org:80... connected! HTTP request sent, awaiting response... 404 Not Found 17:17:53 ERROR 404: Not Found.

ERROR: Can't download http://anonsvn.wireshark.org/wireshark-win64-libs/tags/201 4-10-01/packages//gtk2

NMAKE : fatal error U1077: "C:\cygwin64\bin\bash.EXE": Rückgabe-Code "0x1" Stop.

I use Windows 8.1 64bit, VisualStudio2013 and a 64bit build environment. BTW I don't use any proxy for my internet connection.

Thankfully lal12

asked 13 Jan '15, 08:38

lal12's gravatar image

lal12
367712
accept rate: 33%


I just changed the WIRESHARK_BASE_DIR and it worked. The problem was a space character in the path, I am just confused how this leads to an Error 404 and a wrong download file name.

permanent link

answered 13 Jan '15, 09:27

lal12's gravatar image

lal12
367712
accept rate: 33%

This is the cludgy interface between Windows and Unix that is Cygwin. Something probably ins't quoted properly so the path is split into two arguments.

(13 Jan '15, 09:58) grahamb ♦

Something seems to be wrong with the URL for the package download. If you got to the packages download page you can see the x64 gtk2 packages listed such as gtk+-bundle_2.24.23-1.1_win64ws.zip.

When I run setup (for x86) the gtk2 package request looks like this:

****** gtk+-bundle_2.24.23-1.1_win32ws.zip ******
No HTTP proxy specified (http_proxy and HTTP_PROXY are empty).
Downloading gtk+-bundle_2.24.23-1.1_win32ws.zip into '/cygdrive/e/Wireshark/Wire
shark-win32-libs', installing into gtk2
File 'gtk+-bundle_2.24.23-1.1_win32ws.zip' already there; not retrieving.

So it looks as though something is up in your working copy. Have you made any changes at all, i.e. to config.nmake?

permanent link

answered 13 Jan '15, 09:12

grahamb's gravatar image

grahamb ♦
19.8k330206
accept rate: 22%

It is the same error no matter whether I make changes or not to the config.nmake (I tried this also with the original unchanged files)

(13 Jan '15, 09:16) lal12
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×110
×36
×25
×21
×4

question asked: 13 Jan '15, 08:38

question was seen: 2,297 times

last updated: 13 Jan '15, 09:58

p​o​w​e​r​e​d by O​S​Q​A