This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I know this question has been asked a million times but it just is not working on my new mac, though it worked fine on my previous mac, same model and software. It just opens and closes right away.

I installed X11 and Wireshark. I can launch Wireshark just fine from the X11 terminal but it fails when I try to launch it directly from finder. So far I have done the following.

  1. Reinstalled both the softwares. Still fails.
  2. Moved X11 to trash, launch wireshark and then move X11 back to Applications/Utilities. Still fails.
  3. Deleted the wireshark and wireshark-etc folders from my home directory. Still fails.
  4. Did a "ln -s /opt/X11 /usr/X11". Still fails.

I know I have the right versions since wireshark works just fine via X11 terminal but its really annoying to open X11 all the time I want to use Wireshark. Is there anything I missing here?

asked 13 Jan '15, 12:35

zee's gravatar image

zee
21113
accept rate: 0%


Have you tried 1.99.1 or one of the 1.99.2 automated builds from https://www.wireshark.org/download/automated/osx/ ? The new UI is missing a few features but it should be stable and doesn't rely on X11.

permanent link

answered 13 Jan '15, 12:38

Gerald%20Combs's gravatar image

Gerald Combs ♦♦
3.3k92258
accept rate: 24%

Phew, that worked. Thanks a lot for the help.

(13 Jan '15, 12:43) zee
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×1,620
×108
×13

question asked: 13 Jan '15, 12:35

question was seen: 1,565 times

last updated: 13 Jan '15, 14:37

p​o​w​e​r​e​d by O​S​Q​A