This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hi

I have Windows Seven Home Prenium, fresh installed. When I choose a interface and start a capture, I have this error : The temporary file to which the capture would be saved ("") could not be opened: Permission denied.

What I tried : 1) I checked the global variables TMP and TEMP. It's okay (%USERPROFILE%\AppData\Local\Temp;) I wireshark, About, Folder tab, there is the \Local\Temp folder. 2) I gave all the rights on the Local/Temp for the Guest user, all user etc. 3) My Windows account has the administrator rights 4) I ran the executable as administrator (click right etc.) 5) I installed wireshark (x86 or x64) as administrator, same problem... 6) I tried to install wireshark 1.99...same problem

How can I solve my problem ?

Thank you

asked 14 Feb '15, 17:40

Nico128's gravatar image

Nico128
6223
accept rate: 0%


In the Help -> About Wireshark -> Folders dialog, the Temp folder should be an absolute path, i.e. I have C:\Users\grahamb\AppData\Local\Temp and the Wireshark Temp folder tracks the environment variable "TEMP".

Try opening a command prompt, check the value of the environment var TEMP (echo %TEMP%) adjust if necessary to be an absolute path and then run Wireshark from that command prompt.

permanent link

answered 15 Feb '15, 01:56

grahamb's gravatar image

grahamb ♦
19.8k330206
accept rate: 22%

Hi

I rebooted my computer and now it's work. there is now a new folder named "Temp;" with the char ";". => "AppData\Local\Temp;"

Problem fixed Thank you

(15 Feb '15, 11:15) Nico128

Hi Sirs,

I got the same problem today with the error message.

Even though I use "echo %TEMP%" and it shows the same path as I see in the help dialog, there's still the same error message. Then I tried this:

  1. Go to edit the path of environment variable "TEMP", make it to be "%USERPROFILE%\Local Settings\Temp1". Then the error disappears when I run Wireshark.
  2. Reboot (I'm not sure if need to do this)
  3. Make the "TEMP" path back to "%USERPROFILE%\Local Settings\Temp" and open the porgram. The wireshark works now as normal.

BTW, I got this problem because I used ramdisk and move my "TEMP" to it. When I removed the ramdisk and recoverd the path of "TEMP", it occurs.

Hope this post can save people who have the same problem with me.

BRs,

Mark

permanent link

answered 04 Jan '17, 06:07

hcbamboo's gravatar image

hcbamboo
62
accept rate: 0%

edited 04 Jan '17, 06:13

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×91
×8
×4

question asked: 14 Feb '15, 17:40

question was seen: 30,725 times

last updated: 04 Jan '17, 06:13

p​o​w​e​r​e​d by O​S​Q​A