This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hi all,

I'm running the following tshark scan to get MAC/SSID/signal dbm from probe requests:

sudo tshark -I -i wlan0 -T fields -e wlan.sa_resolved -e wlan_mgt.ssid -e radiotap.dbm_antsignal type mgt subtype probe-req

On a Raspberry Pi. The results are nearly always partial packets, generally just the signal dbm and occasionally an SSID, but pretty much never a MAC address. When I run the same scan on my Macbook Pro in the same room, it generates all three fields for every result. I assumed this was a weaker wifi adaptor on the Pi, so I bought a Linksys AE3000 adaptor (and a couple of others to test), and got the same results. Have tried running the adaptor from a powered USB hub, same result. The Pi is running from a power supply, not battery. Anyone experienced the same thing, or have thoughts on why this is?

asked 19 Mar '15, 08:13

youcloudsofddom's gravatar image

youcloudsofddom
16559
accept rate: 0%


Solved: discovered that the current build of tshark that Debian runs does not support wlan.sa_resolved, hence the 'lack' of data in the packets!

permanent link

answered 22 Mar '15, 02:33

youcloudsofddom's gravatar image

youcloudsofddom
16559
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×832
×134
×9
×5

question asked: 19 Mar '15, 08:13

question was seen: 3,710 times

last updated: 22 Mar '15, 02:33

p​o​w​e​r​e​d by O​S​Q​A