This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Is wireshark's latest version compaitable with QT 5.4.1 and how can we configure that code in qt?

asked 21 Apr '15, 05:04

ankit's gravatar image

ankit
65232328
accept rate: 25%


In my build environment I'm compiling Wireshark master branch with Qt 5.4.1 on Windows without any issue. Then the way to "configure" depends on your platform and build environment. For Windows, you need to set a QT5_BASE_DIR environment variable with the Qt 5.4.1 installation path.

permanent link

answered 21 Apr '15, 05:30

Pascal%20Quantin's gravatar image

Pascal Quantin
5.5k1060
accept rate: 30%

As detailed in the Wireshark Developers Guide, sect. 2.2.9

For OS's other than Windows, it depends on what configure mechanism you use, either autotools or CMake.

(21 Apr '15, 06:11) grahamb ♦

I also want to setup this build environment in windows. I just want to ask that before running .pro file in qt is there any prerequisites that we have to install some tools or some files additionally?

(21 Apr '15, 20:32) ankit

Why are you running the .pro file?

The supported methods to build Wireshark, including the prequisites and setup, are detailed in the Developers Guide.

(22 Apr '15, 01:55) grahamb ♦

ok, got your point grahamb, thanks for suggesting

(22 Apr '15, 20:15) ankit
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×1,620
×23
×8

question asked: 21 Apr '15, 05:04

question was seen: 1,531 times

last updated: 22 Apr '15, 20:15

p​o​w​e​r​e​d by O​S​Q​A