This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

In my captured file (pcap) I can see SIP/SDP packets. But No RTP. I tried decoding UDP as RTP, but still wireshark cannot see RTP sessions. Here is one of the SIP/SDP packet data.

What can be the reason ? Any possible solutions ? I will post more pictures if need more to find the problem. Any suggestions Please. Thanks

UPDATE: I have uploaded the file in cloudshark. This is the link: https://www.cloudshark.org/captures/8dc9fe0edaeb

This question is marked "community wiki".

asked 11 May '15, 03:57

Shas's gravatar image

Shas
19910
accept rate: 0%

edited 11 May '15, 04:46

ANNOUNCEMENT TO ANYONE: DON"T POST PICTURES! These are useless for analysis. Supply capture files through a file share service or cloudshark.

(11 May '15, 04:25) Jaap ♦

Yep, this capture sure helps to understand what's going on.

  1. There's SIP REGISTERs and OKs and these OKs from you have SDP, but where is the INVITE?
  2. There's unidentified UDP traffic to the same box happening, is that call related?

There's HTTPS traffic to the same box. I assume for management/monitoring? Or is it call related?

Does the installation support Compressed RTP? I can't see that packet capture as such.

You're connecting to facebook as well. I guess this is not part of your problem at hand? Might try to clean up your network traffic as good as possible when investigating a problem, this 'noise' makes it harder for you to get a feel for what's happening with your protocol.

(11 May '15, 08:39) Jaap ♦

I see you are using CSipSimple on your Samsung Android smartphone and registering to your Asterisk PBX, but this capture does not include any Call setup (INVITE) that shows any SDP negotiation.....only SDP information pertaining to OPTIONS requests.

Try starting a capture BEFORE your attempted call, and then stopping the capture AFTER the call attempt is terminated.....then repost the new capture.

As far as NOISE goes, that can be filtered out with display filters. Its always good to have to full capture, in case this is an issue at L2.

(11 May '15, 20:13) Rooster_50

@Rooster_50, @Jaap, I tried to capture the session with same application, with same kind of network connection (from the beginning). But now it seems I dont have any SIP/SDP packets. Just UDPs.

(12 May '15, 06:21) Shas
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×238
×139
×109
×6

question asked: 11 May '15, 03:57

question was seen: 2,902 times

last updated: 12 May '15, 06:21

p​o​w​e​r​e​d by O​S​Q​A