This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I have a MACBook Pro (intel i7 / OSX-10 /Yosemite 10.10.3) I downloaded the 64bit version and installed it and it said the installation was successful but the software doesn't start???

asked 29 Jun '15, 16:30

blebrane's gravatar image

blebrane
6112
accept rate: 0%

edited 30 Jun '15, 20:28

Guy%20Harris's gravatar image

Guy Harris ♦♦
17.4k335196

Which exact version of Wireshark?

I know this sounds crazy, but try clicking the app icon and waiting several minutes (yes, minutes). With the Qt-based version of Wireshark (which the Mac OS-X one can be), the first time it runs sometimes takes a very, very long time. I don't know what the holdup is exactly, but Qt does some initialization apparently the first time it runs - though given the length of time, it's probably something timing out/expiring.

After that first time, it should launch pretty fast from then on.

(29 Jun '15, 16:56) Hadriel

I downloaded and installed version 1.12.6 three times. I also started it and waited for about an hour for it to start. When I start it on my MACbook Pro the menu bar at the top has the Wireshark main title but none of the other menu options. Also when I click wireshark menu title I do not get anything useful in the dropdown menu? Also there is no Help or preference menu items?

(30 Jun '15, 14:57) blebrane

Could it be for some kind of reason, that there is a further dialog open? But you are not able to see this. Try right click at the Wireshark symbol at the dock and look if there are more windows open. -> Just a guess, but I had this behaviour once myself.

(30 Jun '15, 15:18) Christian_R

No, I checked all of that. I even shut down the pc and start it up again and it still doesn't work.

(30 Jun '15, 15:27) blebrane

I just tried 1.12.6, and it's still GTK-based for now, which means it's based on X11/XQuartz, so the menu bar you should see at the top of the screen would be the X11 one. It will show "Wireshark" as the left-most menu name of the top-screen at startup, but should then open a window of the Wireshark application, and the left-most menu item on the top-screen bar will change to "X11". (the actual Wireshark menu items will be in a menu bar inside the application window, as opposed to the top-screen menu bar, unlike most Mac applications)

So, if that's not happening... what version of OS X are your running? Some people have reported they had to install XQuartz manually. (though I'd do that as a last resort)

When you installed 1.12.6, did you have a previous version? You usually need to remove it first, by dragging it to the Trash.

Also check if you already have a ".wireshark" or ".wireshark-etc" folders in your home directory and if so then delete them - note the leading "." which means they're hidden, and if you can't see them in Finder then delete them through the Terminal ("rm -rf ~/.wireshark; rm-rf ~/.wireshark-etc"). One note with this is deleting these folders will remove your previous preferences, if you had any.

(30 Jun '15, 15:48) Hadriel

There has been a similar question to non starting wireshark: Wireshark doesnt start after upgrading to yosemite There are a lot of hints where and what you could check. Hope it is usefull to you.

permanent link

answered 30 Jun '15, 16:18

Christian_R's gravatar image

Christian_R
1.8k2625
accept rate: 16%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×15

question asked: 29 Jun '15, 16:30

question was seen: 2,874 times

last updated: 30 Jun '15, 20:29

p​o​w​e​r​e​d by O​S​Q​A