This is our old Q&A Site. Please post any new questions and answers at

I'm using Wireshark 2.0 on Mac OS X (10.11.2)

I want to use the "monitor mode" mentioned in this post(

However, I don't find an option to set the "monitor mode". Does anyone have ideas about this?

asked 08 Dec '15, 00:01

Hanfei%20Sun's gravatar image

Hanfei Sun
accept rate: 0%

Have you scrolled to the right side of the capture dialog?

As shown here:

permanent link

answered 08 Dec '15, 01:43

Christian_R's gravatar image

accept rate: 16%

edited 08 Dec '15, 01:43


I had the same problem, setting the checkbox "monitor mode" had no effekt on my ubuntu 14.04-system. So I tried the following:

Install aircrack-ng

# sudo apt-get install aircrack-ng

Start airmon to see the WLAN-Interfaces

# sudo airmon-ng

Start monitor mode on interface wlan0

# sudo airmon-ng start wlan0

A new interface "mon0" appears. You can capture on this interface with Radio-Information like RSSI, Channel and Transmit-Datarate. You can apply this information as colums in the packet-list.

permanent link

answered 08 Dec '15, 01:59

Uri's gravatar image

accept rate: 0%

I had the same problem, setting the checkbox "monitor mode" had no effekt on my ubuntu 14.04-system.

Different problem - the low-level mechanism used for monitor mode is very different on Linux (which you're using) and OS X (which the person who asked the question is using).

(08 Dec '15, 14:32) Guy Harris ♦♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 08 Dec '15, 00:01

question was seen: 5,261 times

last updated: 08 Dec '15, 14:32

p​o​w​e​r​e​d by O​S​Q​A