This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

In Wireshark 2.0.1, OS X 10.8.5, when I open the application and hit ⌘E it doesn't start a capture with my main interface en0, but I have to hit ⇥⇥↓↑ to select it first. I couldn't find a default interface setting in Preferences > Advanced. I know I can use wireshark -k -i en0 but I wondered if there's another way to this.

asked 18 Feb '16, 07:37

wsk's gravatar image

wsk
21237
accept rate: 0%


How about Preferences -> Capture. That's where you set the default interface. Restart Wireshark and go ahead.[1]

[1] That restart shouldn't be required IMHO.

permanent link

answered 18 Feb '16, 12:11

Jaap's gravatar image

Jaap ♦
11.7k16101
accept rate: 14%

It should put the interfaces in the order in which libpcap returns them, so that the first interface is likely to be the main interface IMHO.

(18 Feb '16, 12:14) Guy Harris ♦♦

:doublefacepalm: thanks!

(18 Feb '16, 12:31) wsk
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×114
×20
×3

question asked: 18 Feb '16, 07:37

question was seen: 1,967 times

last updated: 18 Feb '16, 12:31

p​o​w​e​r​e​d by O​S​Q​A