This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I seem to be having issues with the POSIX paths that have been implemented in Wireshark 1.6.1. I'm on a Windows XP Pro box.

During the setup, the file is being downloaded. I can clearly see it, but I cannot see it through the cygdrive path. If I run the unzip program using the cygdrive path, I get the same error, but if I go the the libs folder and run the unzip program, it unzips fine. So what am I missing here?

Here is the command output:

C:\wireshark-1.6.1>nmake -f Makefile.nmake setup

Microsoft (R) Program Maintenance Utility Version 9.00.21022.08
Copyright (C) Microsoft Corporation.  All rights reserved.

ERROR: The contents of C:\wireshark-win32-libs-1.6\current_tag.txt is (unknown).

It should be 2011-05-19.

Checking for required applications:
        cl: /cygdrive/c/Program Files/Microsoft Visual Studio 9.0/VC/BIN/cl
        link: /cygdrive/c/Program Files/Microsoft Visual Studio 9.0/VC/BIN/link

        nmake: /cygdrive/c/Program Files/Microsoft Visual Studio 9.0/VC/BIN/nmak
e
        mt: /cygdrive/c/Program Files/Microsoft SDKs/Windows/v6.0A/bin/mt
        bash: /usr/bin/bash
        bison: /usr/bin/bison
        flex: /usr/bin/flex
        env: /usr/bin/env
        grep: /cygdrive/c/Program Files/Borland/Delphi7/Bin/grep
        /usr/bin/find: /usr/bin/find
        perl: /usr/bin/perl
        C:\Python27\python.exe: /cygdrive/c/Python27/python.exe
        sed: /usr/bin/sed
        unzip: /cygdrive/c/oracle/product/10.2.0/client_1/bin/unzip
        wget: /usr/bin/wget
        cd C:\wireshark-win32-libs-1.6
        rm -r -f adns-1.0-win32-05ws
        rm -r -f c-ares-1.5.3ws
        rm -r -f c-ares-1.6.0ws
        rm -r -f c-ares-1.7.0-win??ws
        rm -r -f c-ares-1.7.1-win??ws
        rm -r -f gettext-0.14.5
        rm -r -f gettext-runtime-0.17
        rm -r -f gettext-runtime-0.17-1
        rm -r -f gettext-0.17-1            # win64
        rm -r -f glib
        rm -r -f gnutls-2.8.1-1
        rm -r -f gnutls-2.8.5-*-win??ws
        rm -r -f gnutls-2.10.3-*-win??ws
        rm -r -f gtk2
        rm -r -f gtk+
        rm -r -f gtk-wimp
        rm -r -f kfw-2.5
        rm -r -f kfw-3.2.2-ws1
        rm -r -f kfw-3.2.2-i386-ws-vc6
        rm -r -f libiconv-1.9.1.bin.woe32
        rm -r -f lua5.1
        rm -r -f lua5.1.4
        rm -r -f libsmi-0.4.5
        rm -r -f libsmi-0.4.8
        rm -r -f nasm-2.00
        rm -r -f nasm-2.02
        rm -r -f nasm-2.09.08
        rm -r -f pcre-6.4
        rm -r -f pcre-7.0
        rm -r -f portaudio_v19
        rm -r -f portaudio_v19_2
        rm -r -f user-guide
        rm -r -f WpdPack
        rm -r -f AirPcap_Devpack_1_0_0_594
        rm -r -f AirPcap_Devpack_4_0_0_1480
        rm -r -f AirPcap_Devpack_4_1_0_1622
        rm -r -f zlib123
        rm -r -f zlib-1.2.5
        rm -r -f zlib123-dll
        rm -r -f upx301w
        rm -r -f upx303w
        rm -r -f GeoIP-1.4.5ws
        rm -r -f GeoIP-1.4.6-win??ws
        cd "C:\wireshark-1.6.1"

****** gtk+-bundle_2.22.1-20101227_win32.zip ******
No HTTP proxy specified (http_proxy and HTTP_PROXY are empty).
Downloading gtk+-bundle_2.22.1-20101227_win32.zip into /cygdrive/c/wireshark-win
32-libs-1.6, installing into gtk2
--2011-07-19 09:50:46--  http://anonsvn.wireshark.org/wireshark-win32-libs/tags/
2011-05-19/packages//gtk+-bundle_2.22.1-20101227_win32.zip
Resolving anonsvn.wireshark.org (anonsvn.wireshark.org)... 69.4.231.53
Connecting to anonsvn.wireshark.org (anonsvn.wireshark.org)|69.4.231.53|:80... c
onnected.
HTTP request sent, awaiting response... 200 OK
Length: 24516284 (23M) [application/octet-stream]
Saving to: `gtk+-bundle_2.22.1-20101227_win32.zip'

100%[======================================>] 24,516,284  1.20M/s   in 29s

2011-07-19 09:51:15 (816 KB/s) - `gtk+-bundle_2.22.1-20101227_win32.zip' saved [
24516284/24516284]

Extracting /cygdrive/c/wireshark-win32-libs-1.6/gtk+-bundle_2.22.1-20101227_win3
2.zip into /cygdrive/c/wireshark-win32-libs-1.6/gtk2
unzip:  cannot find either /cygdrive/c/wireshark-win32-libs-1.6/gtk+-bundle_2.22
.1-20101227_win32.zip or /cygdrive/c/wireshark-win32-libs-1.6/gtk+-bundle_2.22.1
-20101227_win32.zip.zip.

ERROR: Couldn't unpack /cygdrive/c/wireshark-win32-libs-1.6/gtk+-bundle_2.22.1-2
0101227_win32.zip

NMAKE : fatal error U1077: 'd:\cygwin\bin\bash.EXE' : return code '0x1'
Stop.

C:\wireshark-1.6.1>

asked 19 Jul '11, 06:58

geckofx's gravatar image

geckofx
1111
accept rate: 0%

edited 27 Feb '13, 20:31

helloworld's gravatar image

helloworld
3.1k42041


Don't run the build in a bash shell, use the Windows cmd shell.

permanent link

answered 19 Jul '11, 07:20

Jaap's gravatar image

Jaap ♦
11.7k16101
accept rate: 14%

I am running it in a cmd shell. This same exact process works perfectly for 1.4.x

(19 Jul '11, 10:51) geckofx

I'd have a look at what's in your path. From the mass of output (we don't really need to the output from distclean) the bit that verifies your environment set up shows the following:

...
grep: /cygdrive/c/Program Files/Borland/Delphi7/Bin/grep
...
unzip: /cygdrive/c/oracle/product/10.2.0/client_1/bin/unzip

I think you need to fix this, particularly the unzip and things might work a bit better.

permanent link

answered 21 Jul '11, 03:55

grahamb's gravatar image

grahamb ♦
19.8k330206
accept rate: 22%

Hi, I was getting the same error since last week. Thanks grahamb for drawing attention. :)

(27 Feb '13, 19:54) ankurjain
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×254
×14
×1

question asked: 19 Jul '11, 06:58

question was seen: 5,497 times

last updated: 27 Feb '13, 20:32

p​o​w​e​r​e​d by O​S​Q​A