This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Ocasionaly I use wireshark to decode LAPDm sent in GSM in call setup, reception etc. I use gammu for this purpose and the dump is stored in the xml file. Unfortunately, wireshark does no longer properly interpret this file and shows XML contents instead of separated packets as it worked previously. The sample dump from wireshark's page "gsm_call_1525.xml" is also improperly interpreted. I've tested Ubuntu 15.10, PPA and windows versions. All of them behave the same way. As I can recall, the version from Ubuntu 14.04 worked fine. Can somebody help/advice me to get things working back?

asked 26 Mar '16, 23:20

pz2372901's gravatar image

pz2372901
6113
accept rate: 0%


As Wireshark 2.x has the ability to read and display XML files directly, the file type has to be explicitly set to be a Gammu DCT3 trace to be dissected accordingly.

This is done in the "Open Capture file" dialog, by changing the droplist that appears just below "Read Filter:" from the default of "Automatic" to "Gammu DCT3 trace".

permanent link

answered 27 Mar '16, 11:05

grahamb's gravatar image

grahamb ♦
19.8k330206
accept rate: 22%

That's not new in 2.x; I just built 1.12 from source and it also fails to identify the file as a Gammu dump.

(27 Mar '16, 12:51) Guy Harris ♦♦

This is a bug. I've checked a fix into the master, 2.0, and 1.12 branches, so the fix should show up in the next 2.0.x and 1.12.x releases.

We don't determine whether, or when, they're picked up by distributions, so we don't know whether or when the fix will show up in Ubuntu's repositories. The PPA might pick up the next release when it comes out; if you want something for Ubuntu sooner, you'll have to build from source.

For Windows, if you want something sooner than when the release comes out, you'd have to pick up one of the 32-bit or 64-bit automatic builds. The 2.0.x Windows builds are currently in progress; when they finish, new "2.0.3rc0" builds should show up in those directories. Don't get the gd6ea557 builds, those are the current ones which don't have the fix; wait for a newer one to appear.

permanent link

answered 27 Mar '16, 13:09

Guy%20Harris's gravatar image

Guy Harris ♦♦
17.4k335196
accept rate: 19%

Thanks a lot for both answers as they resolve the issue. I can live with manual selection of dump type although automagic recognition is welcomed. In the near future I'm going to upgrade to Ubuntu LTS 16.*. I hope that developers pick up the corrected version. Thanks to grahamb and Guy Harris one more time.

(27 Mar '16, 22:45) pz2372901
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×37
×36
×1

question asked: 26 Mar '16, 23:20

question was seen: 1,216 times

last updated: 27 Mar '16, 22:45

p​o​w​e​r​e​d by O​S​Q​A