This is our old Q&A Site. Please post any new questions and answers at

NMAKE: fatal error U1077: 'C:\cygwin64\bin\bash.EXE' : return code '0xfe' When I tried to do 'nmake -f Makefile.nmake verify_tools'. The strange thing is that I was able to build with no issue last week, but this week, I am encountering this error. Please suggest.

asked 14 Apr '16, 12:09

christenmu's gravatar image

accept rate: 50%

What version of the source? Please append the full output from your nmake command to your question.

(14 Apr '16, 12:18) grahamb ♦

I had this source code downloaded quite sometime ago. It's master_1.12.

C:\Development\wireshark>"C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\Vcvarsall.bat"
Setting environment for using Microsoft Visual Studio 2010 x86 tools.

C:\Development\wireshark>set WIRESHARK_TARGET_PLATFORM=win64

C:\Development\wireshark>cd C:\Development\wireshark

C:\Development\wireshark>nmake -f Makefile.nmake verify_tools

Microsoft (R) Program Maintenance Utility Version 10.00.40219.01
Copyright (C) Microsoft Corporation.  All rights reserved.

Checking for required applications:
        cl: /cygdrive/c/Program Files (x86)/Microsoft Visual Studio 10.0/VC/BIN/cl
        link: /cygdrive/c/Program Files (x86)/Microsoft Visual Studio 10.0/VC/BIN/link
        nmake: /cygdrive/c/Program Files (x86)/Microsoft Visual Studio 10.0/VC/BIN/nmake
        bash: /usr/bin/bash
        bison: /usr/bin/bison
        flex: /usr/bin/flex
        /usr/bin/find: /usr/bin/find
   2088 [main] bash 680608 fork: child -1 - CreateProcessW failed for 'C:\cygwin64\bin\bash.exe', errno 12
/cygdrive/c/Development/wireshark/tools/ fork: Cannot allocate memory
NMAKE : fatal error U1077: 'C:\cygwin64\bin\bash.EXE' : return code '0xfe'


(14 Apr '16, 12:27) christenmu

I guess rebooting the machine resolved the issue. thanks for your time.

permanent link

answered 14 Apr '16, 13:36

christenmu's gravatar image

accept rate: 50%

That's an issue with your Cygwin installation. Have you updated it since your last successful build?

You also seem to be wanting to make an x64 build with set WIRESHARK_TARGET_PLATFORM=win64 but have started Visual Studio in x86 mode.

permanent link

answered 14 Apr '16, 12:45

grahamb's gravatar image

grahamb ♦
accept rate: 22%

No, I did not install a new cygwin, I don't believe our IT will push a new cygwin on this machine either. I was able to make a build on the visual studio window last week. I just tried it on windows prompt and got the same error. I have just sent an email inquiry to our IT to see whether they changed the cygwin. Do I need to re-install a new cygwin?

(14 Apr '16, 13:13) christenmu
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 14 Apr '16, 12:09

question was seen: 832 times

last updated: 14 Apr '16, 19:19

p​o​w​e​r​e​d by O​S​Q​A