This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hi,

I am using the Windows version of the latest Wireshark (2.0.3) and in most of the sub windows (eg. Capture/Options, Capture/Capture filters, Analyze/Display Filters, Telephony/Voip calls, etc) the language of the button texts does not match the Windows language or the location set in Windows.

I think the language of these texts should be based on the language of Windows.

In Wireshark preferences (Edit/Preferences) the "Language" is set to "System language" under "Appearance".

Has anybody met this issue?

Br, Maegoss

asked 25 May '16, 08:34

Maegoss's gravatar image

Maegoss
6224
accept rate: 0%

edited 25 May '16, 08:39

What language are you expecting?

Are you using the QT version, which does support internationalization and should detect the Windows language setting, or the legacy GTK version which doesn't have any internationalization support?

Apart from looking quite different, you can check for QT or GTK use in Help -> About Wireshark (the "Compiled with... " line) and also check the language in use in the "Running on ..." line.

What do you have set in Edit -> Preferences -> Appearance tab, Language?

(25 May '16, 08:46) grahamb ♦

Hi,

I am expecting Wireshark to use the Windows display language (which is English).

It seems I am using the QT version:

"Compiled (64-bit) with Qt 5.3.2, with WinPcap (4_1_3), with libz 1.2.8, with GLib 2.42.0, with SMI 0.4.8, with c-ares 1.9.1, with Lua 5.2, with GnuTLS 3.2.15, with Gcrypt 1.6.2, with MIT Kerberos, with GeoIP, with QtMultimedia, with AirPcap.

Running on 64-bit Windows 7 Service Pack 1, build 7601, with locale C, with WinPcap version 4.1.3 (packet.dll version 4.1.0.2980), based on libpcap version 1.0 branch 1_0_rel0b (20091008), with GnuTLS 3.2.15, with Gcrypt 1.6.2, without AirPcap. Intel(R) Core(TM) i5-4300M CPU @ 2.60GHz (with SSE4.2), with 8105MB of physical memory."

In Wireshark preferences (Edit/Preferences) under "Appearance" the "Language" is set to "System language". If I set it to "English" the problem disappears.

It seems to be a bug.

Br, Maegoss

(25 May '16, 10:01) Maegoss

And what language did you have before changing the preferences setting?

(25 May '16, 10:13) grahamb ♦
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×6
×4

question asked: 25 May '16, 08:34

question was seen: 1,100 times

last updated: 25 May '16, 10:13

p​o​w​e​r​e​d by O​S​Q​A