This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hi, trying the first time to start Wireshark with Visual Studio 2013 to be able to debug a dissector, I ran into the following issue by just pressing "Play" and running the debugger: Unable to start program "filepath" Access is denied.

For a pro the reason might be clear, however I struggled a bit. What you need to do is to set the startup project to a project in the Executable folder of the solution. I hope this statement is correct. Maybe this could be added in the documentation under 4.6.7.1. Would have saved me some time and since I don't have admin rights the phrase "Access is denied" led me on the wrong path.

Now I can start the debugger an run Wireshark, however now I get several errors from xyz.exe that either libwiretab.dll or libwsutil.dll is missing. When I click "ok" Wireshark starts fine and for playing with a pcap file it does not seem to have consequences. Still I would like to now what I am doing wrong and how I would be able to have "clean" start.

Best regards, Mike

asked 01 Jul '16, 01:15

mikethebo's gravatar image

mikethebo
21447
accept rate: 0%

edited 01 Jul '16, 03:25

grahamb's gravatar image

grahamb ♦
19.8k330206


The issue of not setting the start-up project for debugging is a somewhat basic Visual Studio usage issue when there are multiple executables in a project. I'll look into adding a note into the docs though.

What is "xyz.exe"? Setting Wireshark.exe as the startup project works for me, although for reasons currently unknown, the VS IDE considers a build from the command line as "incomplete" and would like to build some items. This can either be ignored or allow the IDE to build as you see fit.

permanent link

answered 01 Jul '16, 02:50

grahamb's gravatar image

grahamb ♦
19.8k330206
accept rate: 22%

Ok sorry, I have been a little lazy. xyz.exe is only a placeholder for several exes, that give me an error message during start. After starting Wireshark in Visual Studio in debug mode, by changing the start-up project it works, but I get new error messages of the same kind:

xyz.exe - System Error  
The Programm cant' start because libwiretab.dll is missing from your computer. Try reinstalling the programm to fix this problem.

xyz.exe is a placeholder for:
androiddumb.exe
ciscodump.exe
randpktdump.exe
sshdump.exe

There is an error message each for missing libwiretab.dll and libwsutil.dll. I didn't want to post the same error messages 8 times ;-). So I thought I'd go for a variable.

br Mike

(01 Jul '16, 08:39) mikethebo

OK, I've just retested and also see that. These are the extcap executables, so I think there's a DLL load issue in VS such that these executables can't load with the required DLL's. Just running Wireshark.exe from the run\RelWithDebInfo directory works fine. If you don't need the extcap items, the issue can be ignored. I'll have a look to see if anything can be done here.

(01 Jul '16, 08:49) grahamb ♦
1

I've found that if I add the location of the Wireshark executables directory to the path before starting Visual Studio, then starting wireshark in the debugger doesn't generate those errors, e.g.

set PATH=%PATH%;path\to\run\RelWithDebInfo
wireshark.sln

I did try modifying the wireshark project properties in VS, Debugging -> Working Directory to the same location, but that didn't seem to change anything.

(01 Jul '16, 09:10) grahamb ♦

Works for me. Thank you!

(04 Jul '16, 07:14) mikethebo
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×23
×17

question asked: 01 Jul '16, 01:15

question was seen: 2,810 times

last updated: 04 Jul '16, 07:14

p​o​w​e​r​e​d by O​S​Q​A