This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Good morning all,

I'm currently trying to update my 2008 R2 server to the latest stable Wireshark release (2.0.4 64 bit), however I keep getting the error "Wireshark or one of its associated programs is running". I've also tried uninstalling the current version 2.0.3 using the uninstall.exe and the registry uninstall string, but it says that rawshark.exe is in use. The Wireshark folder had rawshark.exe, but the uninstall.exe removed it and then states that it's in use and won't complete the uninstall process.

I've done all of the above using administrative rights on the server, and I don't see rawshark, tshark, or dumpcap running in task manager under any user on this server. What could be causing this uninstall to fail?

asked 08 Jul '16, 05:14

Woody87's gravatar image

Woody87
6113
accept rate: 0%

edited 08 Jul '16, 06:55

Somewhat similar to this question. Can you try the suggestion in my answer there?

(08 Jul '16, 07:35) grahamb ♦

I've downloaded and tried the Process Explorer fix listed in the link you posted, but couldn't find anything running under "wireshark-is-running" or any other wireshark-based processes.

(08 Jul '16, 10:15) Woody87

It's not a process, but a mutex, hence the need to search for a "Handle or DLL ...".

Did you run Process Explorer as an admin, i.e. under the Process Explorer File menu there should not be an item "Show Details for All Processes"?

(08 Jul '16, 10:40) grahamb ♦
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×832
×25
×8

question asked: 08 Jul '16, 05:14

question was seen: 1,260 times

last updated: 08 Jul '16, 10:40

p​o​w​e​r​e​d by O​S​Q​A