This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I have a problem when trying to decrypt a presumably valid ESP packet using AES GCM. I have all the values needed but when trying to apply, whireshark does nothing.. It does not even try to attempt to decrypt. I have tried the same using CBC (with different values ofc) and successfully managed to decrypt it. Is there a reason for this? Is AES GCM not fully implemented? Is there an extra option of some kind I need to set?

asked 02 Aug '16, 04:59

mathildh's gravatar image

mathildh
6112
accept rate: 0%


solved .. the encryption key must be 36 bytes, the first 32 is the key and the last 4 is the salt value

permanent link

answered 02 Aug '16, 05:24

mathildh's gravatar image

mathildh
6112
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×165
×62
×20
×3
×2

question asked: 02 Aug '16, 04:59

question was seen: 1,969 times

last updated: 02 Aug '16, 05:24

p​o​w​e​r​e​d by O​S​Q​A