This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hello,

I tried to install Wireshark to my CentOS machine (offline, no internet connection). I extracted the tar file, then run ./configure and got the following error:

checking for Qt5Core - version >= 5.0.0... no checking for QtCore - version >= 4.7.0... no

configure: error: Qt is not available

I then downloaded Qt 5.7.0 and installed on my machine and run configure again but still get the same error message.

Can you please help me resolve the issue?

asked 03 Aug '16, 08:35

j52652's gravatar image

j52652
6112
accept rate: 0%

edited 03 Aug '16, 09:48

grahamb's gravatar image

grahamb ♦
19.8k330206

What version of Centos and what version of source are you using (or git tag\branch)?

(03 Aug '16, 09:49) grahamb ♦

I am running CentOS 6.3 and the Wireshark version I tried to install was 2.0.5

(03 Aug '16, 09:58) j52652

"downloaded Qt 5.7.0 and installed on my machine" but were these the development packages?

(03 Aug '16, 12:11) Jaap ♦

Yes, Jaap's comment is most likely the problem: you need the development packages too. According to the shell script tools/install_rpms_for_devel.sh these are the packages you'll need to compile with Qt:

qt-devel gcc-c++ qt5-qtbase-devel qt5-qtmultimedia-devel
permanent link

answered 11 Aug '16, 06:36

JeffMorriss's gravatar image

JeffMorriss ♦
6.2k572
accept rate: 27%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×1,620
×41
×15

question asked: 03 Aug '16, 08:35

question was seen: 2,878 times

last updated: 11 Aug '16, 06:36

p​o​w​e​r​e​d by O​S​Q​A