This is our old Q&A Site. Please post any new questions and answers at

When attempting to install Wireshark v1.4.0 (32-bit or 64-bit version using the executable installer) on my Windows 7 computer, I receive the following error message: "Error opening file for writing C:\Program Files\Wireshark\wiretap-0.3.1.dll". I then have to abort the installation. I am not sure how to proceed and did not find this exact issue within Bugzila. Any help is very much appreciated.

asked 14 Sep '10, 07:13

shawn's gravatar image

accept rate: 0%

edited 10 Nov '10, 06:53

Jaap's gravatar image

Jaap ♦

I just ran into the same issue with v1.4.4 and ran as administrator to install. It was successful.

(05 Apr '11, 11:26) Harryw411

Is the installer running the installation with Run as administrator rights, I have Win7 64bit and no probs cant rem when it installed if the installer elevated itself ??

Just an idea might be totally wrong here.

permanent link

answered 15 Sep '10, 11:57

m0rph's gravatar image

accept rate: 0%

I have ran as administrator and re downloaded the install file with still the shame problem.

Here is the Exe info

Filename : C:\Program Files\Wireshark\Wireshark.exe File Size : 3,620,272 Bytes Created Date : 12/19/2013 7:41:56 PM Modified Date : 12/19/2013 7:41:56 PM Executable Format : Portable Executable (32-bit)

MS-DOS Header Information

Bytes in the last page : 144 Number of pages : 3 Relocation entries : 0 Header size in paragraphs : 4 Initial SS (Relative) : 0x0000 Initial SP : 0x00b8 Initial CS (Relative) : 0x0000 Initial IP : 0x0000 Checksum : 0x0000

Portable Executable Header Information

Machine : Unknown Number Of Sections : 6 Number Of Symbols : 0 Optional Header Size : 240 Bytes Time Stamp : 0x52b34bc8 Characteristics : * The application can handle addresses larger than 2gb

Optional Header Information

Linker Version : 10.0 Size Of Code : 1,783,296 Bytes Size of initialized data : 1,942,016 Bytes Size of uninitialized data : 0 Bytes Entry Point : 0x001b2000 Base Of Code : 0x00001000 Base Of Data : 0x40000000

Section Headers Information

This file has 6 sections:

Section Name : .text Virtual Address : 0x00001000 Raw Data Size : 0x001b3600 Raw Data Pointer : 0x00000400 Characteristics : Code, Executable, Readable

Section Name : .rdata Virtual Address : 0x001b5000 Raw Data Size : 0x0007b600 Raw Data Pointer : 0x001b3a00 Characteristics : Initialized Data, Readable

Section Name : .data Virtual Address : 0x00231000 Raw Data Size : 0x0008ce00 Raw Data Pointer : 0x0022f000 Characteristics : Initialized Data, Readable, Writable


(07 Mar '14, 08:29) daniel507

Section Name : .pdata Virtual Address : 0x002da000 Raw Data Size : 0x0000c800 Raw Data Pointer : 0x002bbe00 Characteristics : Initialized Data, Readable

Section Name : .rsrc Virtual Address : 0x002e7000 Raw Data Size : 0x000a3600 Raw Data Pointer : 0x002c8600 Characteristics : Initialized Data, Readable

Section Name : .reloc Virtual Address : 0x0038b000 Raw Data Size : 0x00006a00 Raw Data Pointer : 0x0036bc00 Characteristics : Initialized Data, Readable

Version Information

Operating System : Windows NT, 32-bit Windows File Type : Application File Sub-Type : Unknown File Version : 1,10,5,54262 Product Version : 1,10,5,54262 ============================================================ Product Name : Wireshark File Description : Wireshark File Version : 1.10.5 Product Version : 1.10.5 Company Name : The Wireshark developer community, Internal Name : Wireshark 1.10.5 Legal Copyright : Copyright © 2000 Gerald Combs [email protected], Gilbert Ramirez [email protected] and others Original FileName : Wireshark.exe

(07 Mar '14, 08:30) daniel507

@daniel507, please don't tack comments about your issue onto another question, please use your original question.

(07 Mar '14, 08:35) grahamb ♦

I know this may sound simple but have you tried re downloading the installer? It sounds like it may be corrupted. I too have installed many times on both 32 and 64 bit with no problems.

permanent link

answered 06 Oct '10, 06:54

blacknight's gravatar image

accept rate: 0%

Run install as administrator fixed my install issue for 1.4.1 64 bit which referenced the wiretap-03.1.dll

permanent link

answered 12 Oct '10, 07:54

heyburt's gravatar image

accept rate: 0%

I just ran into the same issue with v1.4.4 and ran as administrator to install. It was successful.


(05 Apr '11, 11:29) Harryw411

Just thought I'd add my two cents as well. My install was constantly aborting until I ran it as an administrator. Then BOOM it worked fine.


(21 Dec '12, 08:40) snifferguy

Had the same administrator problem, now she worked like a charm.

(28 Aug '14, 12:46) ammonitil

This must required the installer with proper administrator rights. May be you will got some other error like task manager error or any problem which relates to wireshark.

(16 Feb '15, 01:10) adambrunam

select Wireshark installer and then right click and choose "Run as administrator"

(07 Oct '15, 18:44) Hisyam

If you're upgrading can you open your Task Manager and look for dumpcap, tshark, or any other Wireshark-related processes? Something might have wiretap-0.3.1.dll open.

permanent link

answered 12 Oct '10, 17:21

Gerald%20Combs's gravatar image

Gerald Combs ♦♦
accept rate: 24%

edited 12 Oct '10, 17:28

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 14 Sep '10, 07:13

question was seen: 28,218 times

last updated: 08 Oct '15, 02:38

p​o​w​e​r​e​d by O​S​Q​A