This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Following HTTP streams was a great addition, particularly when trying to follow servers which send their HTML content gzip'ed.

Strangely enough, the 'HTTP stream' in the popup dialog (or the main menu for that matter), isn't alwys enabled - even when I am clearly inside a TCP packet. (BTW it worked yesterday, same session, even the same capture). When does the HTTP stream option get enabled? Do I have to do anything special?

asked 01 Jan '17, 08:05

jcoppens's gravatar image

jcoppens
6113
accept rate: 0%

Have you selected a packet which has the "HTTP" layer?

(03 Jan '17, 05:25) Lekensteyn

can you share your pcap ?

(05 Jan '17, 23:07) Alexis La Go...

Hello again,

Thanks for reading the original question, and commenting! I've been suffering the follow-up of an Achilles tendon rupture and haven't really been on the computer much. Sorry for the delay in replying!

If I'm not mistaken, my complaint originates from the fact that in the actual Wireshark version, it is necessary to click on the first packet of a TCP stream (i.e. GET, POST, etc). I believe that, when following TCP streams was first implemented (in the last instances of the 1.x series), I could click on any packet of a TCP stream and still get the entire thread selected.

Could that be?

permanent link

answered 13 Jan '17, 13:10

jcoppens's gravatar image

jcoppens
6113
accept rate: 0%

edited 13 Jan '17, 13:12

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×293
×12

question asked: 01 Jan '17, 08:05

question was seen: 2,387 times

last updated: 13 Jan '17, 13:12

p​o​w​e​r​e​d by O​S​Q​A