This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

From the WS capture link below, can anyone tell me why I am getting server retransmission packets from this simple connect/disconnect TCP sequence from my email server? Am I missing an ACK somewhere? I've tried several different extra ACKs, but nothing has worked. Extra ACKs seems to produce 'Duplicate ACK' packets. This is from my own TCP/IP stack.

Thanks.

Sutton

https://www.cloudshark.org/captures/1e8542d7b55c

asked 07 Mar '17, 06:32

dodge55's gravatar image

dodge55
21449
accept rate: 0%

edited 07 Mar '17, 06:50

grahamb's gravatar image

grahamb ♦
19.8k330206


I figured it out. I wasn't adding 1 to the sequence number for the server's FIN packet. So, the seq. number was wrong.

permanent link

answered 07 Mar '17, 06:48

dodge55's gravatar image

dodge55
21449
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×752
×15
×4

question asked: 07 Mar '17, 06:32

question was seen: 1,134 times

last updated: 07 Mar '17, 06:50

p​o​w​e​r​e​d by O​S​Q​A