This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I've run nmake -f Makefile.nmake setup with out any errors. When I run nmake -f Makefile.nmake check_libs I get:

ERROR: The contents of C:\wireshark-win32-libs\current_tag.txt is (unknown). It should be 2011-06-27.

Wireshark is ready to build.

Then when I run nmake -f Makefile.nmake all I get this error:

ERROR: The contents of C:\wireshark-win32-libs\current_tag.txt is (unknown). It should be 2011-06-27.

? Wireshark Libraries not up-to-date ? ? Do you need to run nmake -f Makefile.nmake setup ?

NMAKE : fatal error U1077: 'exit' : return code '0x1' Stop.

I have configured the Config.nmake for my compiler and have followed all the directions. Im trying to build this on windows using visual studio express 2008.

asked 11 Dec '11, 17:54

smithc's gravatar image

smithc
1111
accept rate: 0%

edited 12 Dec '11, 02:44

grahamb's gravatar image

grahamb ♦
19.8k330206

Where are your libraries stored? Is it C:\wireshark-win32-libs-1.6 or somewhere else?

(12 Dec '11, 04:25) Jaap ♦

yeah, it's in C:\wireshark-win32-libs-1.6. I got Wireshark to compile in WinXP, but I still can't get it to compile in Win7.

(12 Dec '11, 23:19) smithc

There should be a file called current_tag.txt in there. What is its contents?

(13 Dec '11, 01:58) Jaap ♦

The contents are 2011-06-27. Thats whats confusing. Maybe its looking somewhere else for current_tag.txt?

(13 Dec '11, 02:57) smithc

You state that your libraries are in "C:\wireshark-win32-libs-1.6" but the error message says the setting for libraries is "C:\wireshark-win32-libs". Which is correct?

(13 Dec '11, 03:30) grahamb ♦

@graham: Whoo, why did you have to spill the beans ;)

@smithc: Graham may be onto something here. Are your path settings in config.nmake in order? Or, did you define WIRESHARK_LIB_DIR yourself?

(13 Dec '11, 03:56) Jaap ♦
showing 5 of 6 show 1 more comments

Like the output indicates, you need to run nmake -f Makefile.nmake setup before running nmake -f Makefile.nmake all.

permanent link

answered 12 Dec '11, 18:32

cmaynard's gravatar image

cmaynard ♦♦
9.4k1038142
accept rate: 20%

I have the same problem

Tried using the "setup" but I get the same output

How can I solve this?

Thanks,

Armando

(05 Jan '12, 14:02) avr989

thanks, I just ignored the error and run the setup, then I closed the cmd and opened it again. Then I followed again steps 2.2.6 thru 2.2.8 and everything went just fine.

(05 Jan '12, 16:53) avr989
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×110
×20
×13
×7

question asked: 11 Dec '11, 17:54

question was seen: 4,376 times

last updated: 05 Jan '12, 19:20

p​o​w​e​r​e​d by O​S​Q​A