This is a static archive of our old Q&A Site. Please post any new questions and answers at

Wireshark setup Linux for nonroot user


Hello there

I've setup Wireshark using 'apt-get install wireshark' and followed the setup-configuration for non-root user (see Wireshark doesn't see my interface).

What I finally did, was following:

sudo groupadd wireshark
sudo usermod -a -G wireshark dionysius
sudo dpkg-reconfigure wireshark-common (and said there YES)

But after that i still cannot see any interface. What am I missing?

edit: if it does matter i'm using linux mint 12

asked 14 Dec '11, 10:19

Dionysius's gravatar image

accept rate: 0%

edited 14 Dec '11, 10:56

multipleinterfaces's gravatar image


4 Answers:


See the answer from a duplicate post.

You don't need to manually add the "wireshark" group; dpkg-reconfigure does it for you. Try removing the group (and your user from the group), run dpkg-reconfigure, add your user back to the group, and then, re-login. I verified these steps in Mint 12:

$ sudo apt-get install wireshark
$ sudo dpkg-reconfigure wireshark-common 
$ sudo usermod -a -G wireshark $USER
$ gnome-session-quit --logout --no-prompt

answered 16 Dec '11, 07:54

helloworld's gravatar image

accept rate: 28%

Perfectly, that was the trick. I suggest to follow the linked post for more details.

(10 Jan '12, 17:34) Dionysius

I have tried the suggested four lines of code above. However at the same time i have "wireshark" group manually added without the "wireshark" user and the code did not work for me. After that i tried to remove the group "wireshark" with "sudo groupdel wireshark" command. Finally the code above is worked for me thank you very much. Best Regards.

(10 Aug '13, 13:37) gokhankelle


Improvement on helloworld's answer

So you dont have to restart gnome, use newgrp to switch groups

$ sudo apt-get install wireshark
$ sudo dpkg-reconfigure wireshark-common 
$ sudo usermod -a -G wireshark $USER
$ newgrp wireshark

answered 21 Mar '16, 02:45

h4ck3rm1k3's gravatar image

accept rate: 0%


Log out and log in again. Adding a currently logged in user to a group using groupadd does not take effect until the user has logged out.

answered 14 Dec '11, 10:55

multipleinterfaces's gravatar image

accept rate: 12%

did that already multiple times (and tested now again). I don't get interfaces without sudo :(

to be sure everything i did is correct?!

[email protected] ~ $ grep "wireshark" /etc/group
(16 Dec '11, 07:33) Dionysius

That was the issue for me, thanks!

(30 Jul '15, 07:48) thewade


dpkg-reconfigure wireshark-common the right answer is no

answered 09 Jan '16, 00:20

Michele%20Pappagallo's gravatar image

Michele Papp...
accept rate: 0%