This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I am unable to build wireshark from the released source. I found a few references to this error but none were resolved. The source is version 1.4.4. Please help.

A verify tools command generates the following:

Checking for required applications:
cl: /cygdrive/c/Program Files/Microsoft Visual Studio 9.0/VC/BIN/cl
link: /cygdrive/c/Program Files/Microsoft Visual Studio 9.0/VC/BIN/link
nmake: /cygdrive/c/Program Files/Microsoft Visual Studio 9.0/VC/BIN/nmake
mt: /cygdrive/c/Program Files/Microsoft SDKs/Windows/v6.1/bin/mt
bash: /usr/bin/bash
bison: /usr/bin/bison
flex: /usr/bin/flex
env: /usr/bin/env
grep: /usr/bin/grep
/usr/bin/find: /usr/bin/find
perl: /cygdrive/c/perl/bin/perl
C:Python27python.exe: /cygdrive/c/Python27/python.exe
sed: /cygdrive/x/SW/GARMIN/sed
unzip: /usr/bin/unzip
wget: /usr/bin/wget

Here's the error generated from "nmake -f Makefile.nmake all"

The system cannot execute the specified program.
NMAKE : fatal error U1077: 'sed' : return code '0x1'

asked 15 Dec '11, 09:25

simply_blue's gravatar image

simply_blue
6225
accept rate: 100%


Try putting your Cygwin first in your Windows PATH before calling nmake. For example:

C:\wireshark_src> set PATH=c:\cygwin\bin;%PATH%
C:\wireshark_src> nmake -f Makefile
permanent link

answered 15 Dec '11, 15:31

helloworld's gravatar image

helloworld
3.1k42041
accept rate: 28%

That seems to have resolved this issue. Thanks! (although, now the build stops at a linking stage)

(19 Dec '11, 07:04) simply_blue

Also for anyone else who hits this issue, you want to set cygwin at the beginning of the path before you run vcvars32.bat

(19 Dec '11, 07:40) simply_blue

I think this question can be closed but I'm too new to do so.

(26 Jan '12, 11:59) simply_blue

@simply_blue if this suggestion fixed your problem, you can mark it as the accepted answer by clicking the checkmark outline underneath the voting buttons. This will mark the question as resolved. There is no need to close the question, as the Q&A format works differently from a forum.

(26 Jan '12, 12:06) multipleinte...

@multipleinterfaces Thanks I was trying to figure out how to do so but i figured I didn't have enough karma yet.

(26 Jan '12, 12:39) simply_blue

sed: /cygdrive/x/SW/GARMIN/sed ????? expected /usr/bin/sed

Something wrong with your path ?

permanent link

answered 15 Dec '11, 09:51

Bill%20Meier's gravatar image

Bill Meier ♦♦
3.2k1850
accept rate: 17%

edited 15 Dec '11, 09:55

That directory is included in the path. I can use sed from the command line (cmd.exe not bash) successfully with other commands. Would it help if I tried to point it to a local install instead of the network drive?

http://seclists.org/wireshark/2010/Dec/5 This guy had the same error with /usr/bin/sed

(15 Dec '11, 10:28) simply_blue

Would it help if I tried to point it to a local install instead of the network drive?

Yes

Your bash (not cmd) path is somehow setup so that the weird sed is found first when looking for sed.

(I'm assuming that the GARMIN/sed is something "not sed").

What is your path from the Bash prompt ?

(15 Dec '11, 10:33) Bill Meier ♦♦

The path from cmd/bash differs only by /usr/local/bin:/usr/bin: being included at the beginning of the bash path. The network drive is included in both.

My understanding, from the developer's guide, is that commands like "nmake -f Makefile.nmake all" should be run from cmd not bash. Which path would the tool verification command use?

Is it possible to remove the X drive from the path used by bash but not the cmd path?

(15 Dec '11, 12:37) simply_blue
1

That sounds like the network drive is in your windows path which is then being picked up by bash.

You'll need to fix the path being used in your cmd prompt before calling nmake.

(15 Dec '11, 12:54) grahamb ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×3

question asked: 15 Dec '11, 09:25

question was seen: 11,110 times

last updated: 26 Jan '12, 12:39

p​o​w​e​r​e​d by O​S​Q​A